Thursday 4 October 2012

/USR FULL IN AIX:


/USR Full In Aix:

# df –g’ ‘df –k’, find out the highly utilized filesystem.

1. move failedlogins into utmp file
Ex: mv /etc/security/failedlogin /etc/utmp

2. find which file and which directory using more space
. To list the files which are over 6 months old:

/usr/bin/find /var -type f \( -name "*.gz" -o -name "*.Z" \) -mtime +186 -exec ls -l {} ';' -exec rm -f {} ';'
Ex:
-rw-r--r--    1 root     system        63079 Jun 27 2007  /var/adm/ras/install_all_updates.log.Z
-rw-r-----    1 root     system     14764428 Dec  1 2009  /var/log/ARCH/failedlogin.0.gz
-rw-r-----    1 root     system        45452 Sep 30 2010  /var/log/ARCH/failedlogin.10.Z
-rw-r-----    1 root     system        32859 Aug 31 2010  /var/log/ARCH/failedlogin.11.Z

3.check the recent application filesets.

#lslpp -h

Ex:

 bos.txt.tfs.data
                  5.3.0.0   APPLY      COMPLETE     12/27/07     14:15:38

  devices.common.IBM.modemcfg.data
                  5.3.0.0   COMMIT       COMPLETE     12/27/07     14:13:44
 bos.txt.spell.data
                  5.3.0.0   COMMIT       COMPLETE     12/27/07     14:15:38

Note:  change apply to commit by using installp -c file setname

           installp -c bos.txt.tfs.data
                     (or)
         installp -Cgx all (it will commit all the file sets)

4. If require increse the file system size.

Ex : #chfs -a size=+1G /usr


No comments:

Post a Comment